Skip to content

116. Troubleshooting Smart Replay export scenarios

This section provides the errors, possible causes and solutions to troubleshoot errors that may occur when exporting a scenario in Smart Reply.

116.1 Must have exactly one SUT

Description:

This error occurs when the test run doesn't contain exactly one Ego.

Possible Causes:

  • There are either zero or multiple Egos in the test run.

Solutions:

  • Choose another test run with exactly one Ego to export a Smart Replay scenario.

116.2 Actor with ID not found in added Actors at the given times

Description:

This error occurs when an actor with a specified ID is not found in the selected time frame to export. This is only relevant for test runs that were originally processed with the Evaluation Pipeline.

Possible Causes:

  • The time range selected for export was changed after the actor was selected.
  • The time viewed in the debugger was moved outside the selected time range to export, and a vehicle was added that does not exist in the selected time range.

Solutions:

  • Verify all selected actors exist in the selected time range.
  • Deselect all actors and reselect, making sure not to include vehicles that don't exist in the selected time range.